All systems operational

Billing Panel Migration

Completed
Scheduled for June 25, 2022 at 9:26 PM – 10:00 PM

Affected

Panels
Billing Panel
Updates
  • Completed
    June 25, 2022 at 10:00 PM
    Completed
    June 25, 2022 at 10:00 PM

    Maintenance has completed successfully.

  • In progress
    June 25, 2022 at 9:27 PM
    In progress
    June 25, 2022 at 9:27 PM

    Maintenance is now in progress.

  • Planned
    June 25, 2022 at 9:26 PM
    Planned
    June 25, 2022 at 9:26 PM

    We are planning for a scheduled maintenance of the billing panel.